LNMP最新文章

LNMP一键安装包是一个用Linux Shell编写的可以为CentOS/RHEL/Fedora/Debian/Ubuntu/Raspbian/Deepin/Alibaba/Amazon/Mint/Oracle/Rocky/Alma/Kali/UOS/银河麒麟/openEuler/Anolis OS Linux VPS或独立主机安装LNMP(Nginx/MySQL/PHP)、LNMPA(Nginx/MySQL/PHP/Apache)、LAMP(Apache/MySQL/PHP)生产环境的Shell程序。1

linux更改用户组
[ LNMP] linux更改用户组
更改用户chown -R username dirname用户组chgrp -R username dirname
ERROR! MySQL is running but PID file could not be found
[ LNMP] ERROR! MySQL is running but PID file could not be found
报错:ERROR! MySQL is running but PID file could not be found原因:mysql进程异常解决办法:找到并kill掉所有关于mysql的进程执行==》ps -ef | grep mysql 查看相关进程执行==》kill 进程号启动MySQL服务 sudo /usr...
LNMP一些优化建议
[ LNMP] LNMP一些优化建议
修改/usr/local/php/etc/php-fpm.conf php 5.2调整:max_children的值php 5.3以上版本调整:pm.min_spare_servers和pm.max_spare_servers的值适当增加最大值可以按内存xxMB/2/20 的整数来算,最小值可以按内存/2/40 的整数...
Mysql的一些优化建议
[ LNMP] Mysql的一些优化建议
MariaDB性能优化参数设置性能配置innodb_buffer_pool_size=1GInnoDB 引擎在内存中有一个缓冲池用于缓存数据和索引,这当然有助于你更快地执行MySQL/MariaDB 查询语句。这是InnoDB 最重要的设置,对InnoDB性能有决定性的...
分卷压缩
[ LNMP] 分卷压缩
zip -s 300m -r myerp.zip ./kz.baidu.cn -x ./kz.baidu.cn/public/kz.zip解压cat myerp.* > myerp_all.tar.gz
iptables命令行
[ LNMP] iptables命令行
CentOS7防火墙放行或限制指定IP和端口(firewall)CentOS7默认没有安装iptables,可以手动安装iptables;也可以通过CentOS7已带的firewall配置防火墙。1.查看firewalld.service服务状态systemctl status firewalld2.查看fire...
windows创建软连接
[ LNMP] windows创建软连接
C:\Windows\system32>mklink /J E:\home\wwwroot\www.baidu.com\public\uploads E:\home\wwwroot\www.baidu.com\writable\uploads==========为 E:\home\wwwroot\www.baidu.com\public\uploads \home\wwwroot\www.ba...
Nginx执行超时
[ LNMP] Nginx执行超时
nginx配置中fastcgi_read_timeout指定了nginx接受后端fastcgi响应请求超时时间,默认是60秒,如果fastcgi在规定时间内没有返回数据,就会直接返回图1的提示给客户端。所以把php的脚本最大执行时间设置大一点,并在及时返回给...
shell查询是否有字符串
[ LNMP] shell查询是否有字符串
例如#!/bin/shFIND_FILE="/etc/config/samba"FIND_STR="udisk01"if[`grep-c"$FIND_STR"$FIND_FILE`-ne'0'];thencp/etc/config/samba.ok/etc/config/samba/etc/init.d/sambarestartexit0fi
ubuntu安装iptables
[ LNMP] ubuntu安装iptables
apt purge ufw iptablesapt install iptablesupdate-alternatives --set iptables /usr/sbin/iptables-legacyupdate-alternatives --set ip6tables /usr/sbin/ip6tables-legacy